[实用类模块] 本土化易模块(多功能)

[复制链接]
查看276 | 回复6 | 2019-10-26 14:45:25 | 显示全部楼层 |阅读模式
1.jpg
2.jpg
3.jpg
4.jpg


模块名称:本土化易模块
作者:王军收集
版本:1.89

收集了论坛上一些较常用的模块,现在有89个可用的,其他未完成的大家一起来搞吧.这些可以直接作为模块使用,或直接将子程序拷贝到你自己的程序中使用.

------------------------------

.版本 2

.子程序 表达式计算, 文本型, 公开, 成功返回计算后的文本结果,失败返回空文本
.参数 Text, 文本型
.参数 单位, 逻辑型, , 函数计算时使用,真为弧度制,假为角度制

.子程序 查看字节集, 文本型, 公开, 以文本表示字节集,适合于字节集的调试用,查看字节集可以将一串字节集用文本形式表示出来,极大地方便了调试字节集变量。
.参数 原始字节集, 字节集, , 要查看的字节集

.子程序 创建任意目录, 整数型, 公开, -1 失败, 0 已存在,1 成功创建
.参数 欲创建的目录名称, 文本型

.子程序 创建文件目录, 逻辑型, 公开, 根据一个文件名创建出该文件名所包含的所有目录
.参数 文件名, 文本型, , 完整路径的文件名

.子程序 倒取文本, 文本型, 公开
.参数 字串, 文本型, , 要进行处理的文本字符串
.参数 识别汉字, 逻辑型, 可空, 是否对文本中的汉字进行识别处理;缺省为不识别,即默认为"假"
.参数 个数, 整数型, 可空, 缺省为取所有,否则倒取文本的字符数为给定的“个数”的值

.子程序 二分查找, 整数型, 公开
.参数 数组, 文本型, 数组
.参数 待查, 文本型
.参数 类型, 整数型
.参数 区分大小写, 逻辑型

.子程序 复制目录, , 公开
.参数 被复制目录, 文本型, , 形式如:"c:\windows"等
.参数 复制到的目录, 文本型, , 形式如:"e:\bak\win98"等

.子程序 改后缀, 文本型, 公开, 改变一个文件的后缀名,如果没有后缀,将自动加上新后缀,返回新文件名
.参数 原始文件名, 文本型, , 需要处理的原始文件名
.参数 新后缀名, 文本型, 可空, 如果新后缀名为空,即直接返回原文件名

.子程序 还原三原色, 整数型, 公开, 返回易语言中颜色数值所对应的某一个RGB单色数,-1表示失败
.参数 颜色值, 整数型, , 易语言的颜色数
.参数 需取的色, 整数型, , 1=R,2=G,3=B,4=H,5=HTML

.子程序 还原网页颜色, 文本型, 公开, 转换颜色值到网页颜色的代码
.参数 颜色值, 整数型

.子程序 还原为字节集, 字节集, 公开, 将一串十六进制文本还原为字节集。还原为字节集可以将默认的16进制文本转换成字节集。如“00BFAD00”可还原为{0,191,173,0}
.参数 原始16进制文本, 文本型, , 如“00BFAD00AFD4FD4F9E054F9FF91FC5FF2076FBAFDB071044”

.子程序 函数计算, 文本型, 公开, 求正弦、余弦、正切、余切
.参数 Text, 文本型
.参数 单位, 逻辑型, , 真为弧度制,假为角度制

.子程序 合并文件, , 公开, 将两个文件进行合并,生成一个新的文件
.参数 合并文件名, 文本型, , 前一个文件名,最后生成的文件名也是它.
.参数 被合并文件名, 文本型, , 要追加的文件名.
.参数 生成文件名, 文本型, 可空, 如果空,以第一个文件名为准

.子程序 加入IE工具栏, 逻辑型, 公开

.子程序 加入右键菜单, 逻辑型, 公开

.子程序 加易语言快捷方式到IE浏览器, 逻辑型, 公开
.参数 图标所在路径文件名, 文本型, , 用于加载到IE浏览器快捷按钮上所用原始图标的路径文件名,以ICO结束,如:"e.ico"
.参数 提示文字, 文本型, , 用于在IE浏览器中用于提示的文字,如:“易语言3.6”
.参数 添加还是清除, 逻辑型

.子程序 建立关联, 逻辑型, 公开, 能用于关联程序打开方式及改关联图标,以及取得程序关联等功能。
.参数 后缀, 文本型, , 要关联的文件后缀,如"*.txt"
.参数 关联程序, 文本型, 可空, 此后缀所要关联的程序,如"d:\myflash.exe",会关联用此程序打开,如果为空则默认为本程序
.参数 关联图标, 文本型, 可空, 关联后此程序的图标,默认为关联程序的第一个图标
.参数 关联名称, 文本型, 可空, 此为高级项,为关联注册项的名称,可为空,默认为程序名

.子程序 快速查询, , 公开, 在易数据库已打开的情况下,对某字段进行快速查询,勤快的人可把记录分成两个数组,用多线程分开查询,应该更快。把记录添加完了在显示控件,这样就快多了
.参数 查询的字段名, 文本型, , 必须为文本型字段
.参数 查询内容, 文本型, 可空, 可以为空,为空即为查询空记录
.参数 返回记录号数组名, 整数型, 数组, 本数据内容将直接返回结果

.子程序 括号计算, 文本型, 公开
.参数 Text, 文本型

.子程序 目录是否存在1, 逻辑型, 公开, 输入一个目录名,判断此目录是否存在
.参数 目录名, 文本型, , 1是用"取文件属性法查找"

.子程序 目录是否存在2, 逻辑型, 公开, 输入一个目录名,判断此目录是否存在
.参数 目录名, 文本型, , 2是"写文件法查找目录"

.子程序 内部计算, 文本型, 公开, 加减乘除及乘方运算,失败返回空文本
.参数 Text, 文本型

.子程序 判断文件或目录, 整数型, 公开, 判断给出的字符串名到底是文件还是目录.1为文件,2为目录,0表示对象不存在
.参数 名称, 文本型

.子程序 判断有无子目录, 逻辑型, 公开, 判断一个目录下有无下级子目录
.参数 当前目录, 文本型, , 若没有以"\"结尾,将自动增加

.子程序 清空系统临时目录, 逻辑型, 公开
.参数 是否删除只读文件, 逻辑型, 可空
.参数 是否删除子目录, 逻辑型, 可空

.子程序 取DOS路径, 文本型, 公开, 返回DOS 8.3路径名
.参数 原路径, 文本型

.子程序 取GB2312简体汉字笔画数, 整数型, 公开, 作者:袁晓辉(海洋)
.参数 汉字, 文本型

.子程序 取IP段, 文本型, 公开
.参数 IP地址, 文本型, 可空, 如果为空或空白,即取本机主机名

.子程序 取MP3播放时间, 文本型, 公开, Mp3文件的全曲时间,仅支持MP3文件,如果文件不存在,将返回空
.参数 文件名, 文本型, , Mp3文件的全路径名
.参数 时间样式, 整数型, 可空, 1为X秒,2为X分X秒,3为X:X,默认为2

.子程序 取单独文件名, 文本型, 公开, 可取含扩展名的与不含扩展名的
.参数 文件名, 文本型
.参数 是否要后缀, 逻辑型, 参考, 如果为空,为带有后缀.

.子程序 取繁体汉字笔划, 整数型, 公开, 作者:王军,如果没有找到,就返回 -1
.参数 文字, 文本型

.子程序 取格式年月日, 文本型, 公开, 调用子程序返回"0000-00-00"格式的日期格式,可以换成日期框里的日期
.参数 日期时间, 日期时间型

.子程序 取格式时分秒, 文本型, 公开, 以00:00:00方式显示时分秒
.参数 原始时间, 日期时间型

.子程序 取公历节日, 文本型, 公开, 根据公历年月日,返回公历的节日,某些节日需要有年代才能确定是星期几.
.参数 公历年, 整数型, 可空
.参数 公历月, 整数型, 可空
.参数 公历日, 整数型, 可空

.子程序 取关联, 文本型, 公开, 写入一个后缀,取得此后缀文档打开方式,失败则返回空文本
.参数 后缀, 文本型, , 文件后缀,如"txt","*.txt",".txt"三者都可以

.子程序 取汉字机内码, 文本型, 公开
.参数 汉字, 文本型

.子程序 取汉字区位码, 文本型, 公开, 返回一个汉字的区位码,如果汉字过长,只取第一个字,如果不是汉字,返回空
.参数 汉字, 文本型, , 传送一个汉字进行处理
.参数 区码还是位码, 整数型, 可空, 需返回的内容,1表示区码,2表示位码,3表示区码与位码都返回,默认为3

.子程序 取汉字区位码2, 文本型, 公开
.参数 汉字, 文本型

.子程序 取行右边, 文本型, 公开, 从文本的右边按标志文本开始寻找, 取行右边 (“1234567890”, “5”, 1, 真)
.参数 文本, 文本型, , 被查找的文本
.参数 标志文本, 文本型, , 标志文本
.参数 起始寻找位置, 整数型, 可空, 标志文本的起始寻找位置,最好为空,默认取文本总长度,这样才能真正从最后向前开始找.
.参数 是否区分大小写, 逻辑型, 可空, 默认为假,区分大小写

.子程序 取行中间, 文本型, 公开
.参数 文本, 文本型, , 被查找的文本
.参数 前标志文本, 文本型, , 前面的一个标志文本
.参数 后标志文本, 文本型, , 从前标志文本+1位置起查找的标志文本
.参数 起始寻找位置, 整数型, 可空, 前标志文本位置+1位置
.参数 是否区分大小写, 逻辑型, 可空, 默认为不区分大小写

.子程序 取行左边, 文本型, 公开, 从文本的左边按标志文本开始寻找
.参数 文本, 文本型, , 被查找的文本
.参数 标志文本, 文本型, , 标志文本
.参数 起始寻找位置, 整数型, 可空, 标志文本的起始寻找位置
.参数 是否区分大小写, 逻辑型, 可空, 默认为假区分大小写



本土化易模块.rar (39.83 KB, 下载次数: 0)
回复

使用道具 举报

血薇 | 2019-10-30 23:39:31 | 显示全部楼层
真很不错...
回复

使用道具 举报

十二月的奇迹 | 2019-11-2 11:09:40 | 显示全部楼层
希望多发点这样的好东西
回复

使用道具 举报

AllureLove | 2019-11-4 13:57:14 | 显示全部楼层
总的来说不错
回复

使用道具 举报

°Distance | 2019-11-7 12:52:29 | 显示全部楼层
好,很好,非常好!!!
回复

使用道具 举报

Vulgar | 7 天前 | 显示全部楼层
我正在找这个呢,谢谢了
回复

使用道具 举报

逆风方向 | 前天 04:00 | 显示全部楼层
可以的,,,,,顶一下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则